Teamviewer 640x480 Without Monitor

Posted By admin On 27/11/21
Hi
Some time ago I started making plans to create a home server and asked for some general advice (https://forums.opensuse.org/showthre...ce-for-my-SOHO). Well, I'm now getting round to doing it and falling into the inevitable problems, so I'm seeking advice. I've already asked for help with Samba.
My second problem relates to remote management of the server. I'm currently using TeamViewer to log into the server and do what I need to in the GUI. This may not be the long-term solution, but it's a quick and easy start. However, I'm experiencing a problem which I suspect may be common to whatever approach I ultimately take.
When I connect via TeamViewer, I only get the desktop if a monitor is plugged in (it doesn't need to be powered up, but it does need the VGA cable to be plugged in). If I attempt to connect without the monitor plugged in it fails to return an image for the desktop (though a connection is successfully made). To me, it appears that no monitor = no image being created = no image for TeamViewer to obtain.
My fear is that this will occur no matter what tool I use to connect, and I need to find some solution (e.g. fake EDID, virtual desktop, etc.). Searching for solutions has not put me on what I think is the right path.
Suggestions?
Thanks
Stuart
  1. Teamviewer Resolution 640x480 Without Monitor
  2. Resolution Stuck On 640x480
640x480Teamviewer resolution 640x480 without monitor
Hello,
I have a specific problem I am unable to solve on my own, so I ask for your help. I have LEAP 42.1 installed on a DELL PC with Intel integrated GPU. Installation was fine but when I was preparing my PC I found out one big issue. I need to access my PC remotely via VNC, occasionally with TeamViewer.. It works great as long as I have a monitor plugged in. At the very moment I unplug it, my VNC or TW screen goes black and that's it. When I plug the monitor back in, the screen will reappear.
Using KDE with Plasma 5.
Integrated GPU.
Using X11VNC.
Another problem that goes with this is when I boot the PC without monitor plugged. The PC goes up, and when I plug the monitor cable into the PC, I still have no screen. The monitor won't receive signal from PC. I have to restart the computer and then it works.
I don't have any of these problems on Windows. Only here on SUSE 42.1. Anybody got ideas how to set this up ? That means if I start the PC without monitor attached, the screen will go up as usual ? And when I unplug the monitor from a running PC the remote screen won't go black ?
Thank you very much

My Windows desktop has a LG 4K monitor and Radeon x570 graphics card. The latest drivers are installed for both devices. I have the latest build of TV 13 installed. If I turn on my computer with the monitor off, the TV remote resolution is stuck at 640x480. There are no other resolutions offered. The problem is that with no monitor attached, the remote desktop has only 1024x768 resolution. Xrandr shows LVDS1 to be connected, although it isn't, and it only allows 1024x768 resolution. The solution appears to entail using xrandr to test resolution, and then inserting the xrandr commands somewhere to execute the commands on startup/login.

Teamviewer Resolution 640x480 Without Monitor

Without

Resolution Stuck On 640x480

  1. When I connect via TeamViewer, I only get the desktop if a monitor is plugged in (it doesn't need to be powered up, but it does need the VGA cable to be plugged in). If I attempt to connect without the monitor plugged in it fails to return an image for the desktop (though a connection is successfully made).
  2. You can boot up with monitor, and unplug it after; but they just don't seem to boot without a display. I use HDMI EDID emulators now (available on from a Latvian seller on ebay for about U$15, emulates a 4k monitor so you can remote use teamviewer or similar at whatever resolution you want).